logo 业务广告位招租联系QQ:3257874327
  • 首页
  • 易语言教程
  • 易语言源码
  • 视频教程
  • 2019年香港四不像正版
  • 推荐分享
  • 网络教程
  • 站内搜索:
    您的位置:易语言教程 >> 易语言教程 >> 易语言教程
    学习讨论群1:易语言教程 学习讨论群2: 易语言教程②
    易语言组件移动边缘检测
    发稿作者:管理员   ‖  发布时间:2017-8-21 19:08:05  ‖  查看1860次  ‖  




    易语言组件移动边缘检测代码


    .版本 2


    .程序集 窗口程序集_窗口1

    .子程序 _窗口1_按下某键, 逻辑型
    .参数 键代码, 整数型
    .参数 功能键状态, 整数型

    .判断开始 (键代码 = #A键)
    按钮2.左边 = 按钮2.左边 - 1
    .判断 (键代码 = #D键)
    按钮2.左边 = 按钮2.左边 + 1
    .判断 (键代码 = #W键)
    按钮2.顶边 = 按钮2.顶边 + 1

    .判断 (键代码 = #S键)
    按钮2.顶边 = 按钮2.顶边 - 1
    .默认

    .判断结束
    刷新显示 ()

    .子程序 _按钮2_按下某键, 逻辑型
    .参数 键代码, 整数型
    .参数 功能键状态, 整数型
    .局部变量 a, 逻辑型

    a = 假
    a = 判断物体 ()
    .如果 (a = 真)
    标签1.标题 = “不要怼我”
    .如果真 (键代码 = #A键)
    按钮2.左边 = 按钮2.左边
    .如果真结束
    .如果真 (键代码 = #D键)
    按钮2.左边 = 按钮2.左边
    .如果真结束
    .如果真 (键代码 = #W键)
    按钮2.顶边 = 按钮2.顶边
    .如果真结束
    .如果真 (键代码 = #S键)
    按钮2.顶边 = 按钮2.顶边
    .如果真结束

    .否则
    标签1.标题 = “快来怼我”
    .如果结束
    .如果真 (键代码 = #A键)
    按钮2.左边 = 按钮2.左边 - 1
    .如果真结束
    .如果真 (键代码 = #D键)
    按钮2.左边 = 按钮2.左边 + 1
    .如果真结束
    .如果真 (键代码 = #W键)
    按钮2.顶边 = 按钮2.顶边 - 1
    .如果真结束
    .如果真 (键代码 = #S键)
    按钮2.顶边 = 按钮2.顶边 + 1
    .如果真结束


    .子程序 判断物体, 逻辑型
    .局部变量 左边缘
    .局部变量 右边缘
    .局部变量 上边缘
    .局部变量 下边缘

    左边缘 = 分组框1.左边
    右边缘 = 分组框1.左边 + 分组框1.宽度
    上边缘 = 分组框1.顶边
    下边缘 = 分组框1.顶边 + 分组框1.高度
    .如果真 (按钮2.左边 ≥ 左边缘 且 按钮2.左边 ≤ 右边缘)
    .如果真 (按钮2.顶边 ≥ 上边缘 且 按钮2.顶边 ≤ 下边缘)
    返回 (真)
    .如果真结束

    .如果真结束
    .如果真 (按钮2.左边 + 按钮2.宽度 ≥ 左边缘 且 按钮2.左边 + 按钮2.宽度 ≤ 右边缘)
    .如果真 (按钮2.顶边 + 按钮2.高度 ≥ 上边缘 且 按钮2.顶边 + 按钮2.高度 ≤ 下边缘)
    返回 (真)
    .如果真结束

    .如果真结束
    .如果真 (按钮2.左边 + 按钮2.宽度 ≥ 左边缘 且 按钮2.左边 + 按钮2.宽度 ≤ 右边缘)
    .如果真 (按钮2.顶边 ≥ 上边缘 且 按钮2.顶边 ≤ 下边缘)
    返回 (真)
    .如果真结束

    .如果真结束
    .如果真 (按钮2.左边 ≥ 左边缘 且 按钮2.左边 ≤ 右边缘)
    .如果真 (按钮2.顶边 + 按钮2.高度 ≥ 上边缘 且 按钮2.顶边 + 按钮2.高度 ≤ 下边缘)
    返回 (真)
    .如果真结束

    .如果真结束
    返回 (假)
    上一篇: 易语言开机启动源码演示
    下一篇: 易语言遇到需要很多变量怎么办
    代金券
    评论功能暂时关闭

    本网站致力于易语言编程资源整合收集,部分资源永久保存服务器提供下载和技术学习使用,欢迎大家提供资源。

    备案号:蜀ICP备16001169号